Back to overview
Resolved

Server delay

Jun 18, 2024 at 10:11am UTC
Affected services
Server 1 (Prod1)

Resolved
Jun 18, 2024 at 10:16am UTC

We are back again. Sorry again for the delay!

Created
Jun 18, 2024 at 10:11am UTC

We are currently experiencing delays on our servers. Apologies for the inconvenience and we are currently trying to scale up.