Back to overview
Resolved

Slow performance

May 18, 2023 at 6:32pm UTC
Affected services
Server 1 (Prod1)

Resolved
May 18, 2023 at 7:00pm UTC

All services are stable again

Updated
May 18, 2023 at 6:42pm UTC

We have identified the cause of degraded performance and are currently monitoring the performance improving again.

Created
May 18, 2023 at 6:32pm UTC

We notice degraded performance on our platform. We are aware of this and investigating this incident.