Back to overview
Resolved
Degraded Performance — Investigating
Sep 16, 2026 at 11:05am UTC
Affected services
Server 1 (Prod1)
Resolved
Sep 16, 2026 at 11:09am UTC
This incident has been resolved. Plate Multisite is fully operational and performing normally again.
We apologize for any inconvenience this may have caused. Thank you for your patience.
Affected services
Created
Sep 16, 2026 at 11:05am UTC
We are currently experiencing degraded performance affecting Plate Multisite. Our team has identified unusual traffic patterns and is actively investigating and mitigating the issue.
Users may experience slow response times. We will post updates here as we have more information.
Affected services