Increased spam submissions via forms
Resolved
Aug 31, 2026 at 8:48am UTC
The fix has been deployed and it appears to have resolved the issue with spam submissions bypassing our filtering. We're continuing to monitor the situation closely to confirm the issue doesn't reoccur. We'll post a final update once we're confident this is fully resolved.
Affected services
Updated
Aug 31, 2026 at 8:07am UTC
Customers are still experiencing spam emails in their inbox as a result of form submissions not being properly filtered. This remains a high priority for us. We believe we've identified a fix for the issue and are currently validating it before rolling it out. We'll post another update once it's confirmed and deployed.
Affected services
Created
Aug 28, 2026 at 7:52am UTC
We're aware that some customers are currently receiving an increased volume of spam submissions through their Plate forms. Our investigation indicates that reCAPTCHA is not filtering these submissions as expected in all cases. We're actively investigating the cause and working on a fix. This page will be updated as soon as we have more information.
Affected services